Versione pasw2015 per php7

26 Gennaio 2019 in Wordpress

Il passaggio del dominio da gov a edu è l’occasione anche per aggiornare le versioni di php presenti nell’hosting che viene offerto. La versione pasw2015 presenta un errore con php7.

Marco Milesi propone una versione di testing del tema pasw2015 che è possibile scaricare e provare nel proprio sito.

Già qualcuno ha provato ad utilizzare questa versione che per ora non ha dato problemi. Per chi avesse quindi necessità ecco le istruzioni:

  • scarica il pacchetto da questo indirizzo http://mmilesi.ml/pasw2015.zip
  • caricalo via ftp nello spazio web sostituendo il tema in uso (si trova nella cartella /wp-content/themes)
  • comparirà un messaggio indicante di installare, e poi attivare, un nuovo plugin: “GitHub updater”.
  • Verifica che il tutto vada a buon fine, ovvero che al termine il messaggio scompaia e che il plugin risulti effettivamente installato nella lista dei plugin

Aggiornamento 27 gennaio 2019

È necessario fare due correzioni:

  • nel file contenuto in wp-content/themes/pasw2015/include/widget.php alla linea 433 e 435 si dovranno inserire gli apici.
    Riga 433 da if (function_exists(Is_Circolare_per_User)) a if (function_exists(‘Is_Circolare_per_User’))
    riga 435 da if (function_exists(gcg_Is_Circolare_per_User)) a if (function_exists(‘gcg_Is_Circolare_per_User’))
  • il passaggio a php7 evidenzia un problema nel plugin AVCP da correggere in questo modo
    nel file contenuto in wp-content/plugins/avcp/tablegen.php alla riga 23
    riga 23 da query_posts( array( ‘post_type’ => ‘avcp’, ‘orderby’ => date, ‘order’ => DESC, ‘posts_per_page’ => -1, ‘annirif’ => $anno) ); a query_posts( array( ‘post_type’ => ‘avcp’, ‘orderby’ => ‘date’, ‘order’ => ‘DESC’, ‘posts_per_page’ => -1, ‘annirif’ => $anno) );

 

Lascia una risposta

Devi essere loggato per inviare un commento.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

Vai alla barra degli strumenti